Flamingo nXt

easy rendering for Rhino in Windows

I stopped a rendering, then tried to save it.  I get the error message:

"Unable to create save bitmap"

Do I need to purchase a license at this point?

Any ideas?

Thanks up front for any help.

Cheers!

-Mike

Views: 566

Reply to This

Replies to This Discussion

Hello Mike,

I am attempting to track down the problem but need a little more information to figure it out.  Does this fail every time you try to save after a rendering or only in specific models?  Can you try starting Rhino, draw a box or sphere or something that will render, start the render command, wait for a pass or two, press the "Stop" button then try a simple save.  If that fails could you press F2 and look see if there is any additional error information in the history window.

I searched the code for the "Unable to create save bitmap" error message and added some additional messaging to help identify why it may be failing and will be releasing a new beta shortly with this new code.

Thanks for the help in tracking this down, I'm sorry it is not working for you.

There are many possibilities here.  Can you trya few things?

1) Render at a lower resolution.  Will it save?

2) Turn off most of the model, then render at your current resolution, will it save?

3) Do you use suspend and resume rendering?

This problem is lingering around.  We are having trouble understanding the specific cause.

Here's what I found John - & Scott:

I tried with two models, one about 4Mb, the second about 113Mb.  Tried turning off everything but the groundplane in the small one - no luck.

Then I shut down the machine - Dell Inspiron Laptop, 1.8Ghz processor, 2gb ram, running in 3gb mode WindowsXp - 32 bit - turned it off, waited a few minutes, booted back up, opened Rhino5, opened the small drawing, hit render, stopped after 5 passes & it let me save the image as a .jpg.  I continued the render one more pass, tried to save, it would not let me save.

I opened the large drawing, rendered a view with very few objects visible - most layers turned off - ran 2 passes, it would not let me save.  I tried re-opening the small drawing, rendered 2 passes in a simple view, would not let me save.  I hit F2 - nothing happened, did not show any more text in the command line.

It seems that the first time I open Rhino & render it will let me save, but not after that until I re-boot the machine.  I even tried just closing Rhino, waiting a few minutes, re-opening Rhino, render & try to save - nothing.

I thought that maybe the installation of Rh5 or FlamingoNxt were corrupt or something, so I re-downloaded & re-installed both.  No change.

I just tried it on another machine - Dell Optiplex GX 280 2.8ghz processor, 2Gb ram, WinXpPro 32 bit  installed FlamingoNxt, opened Rh5 latest, opened the small file, rendered 3 passes, & tried to save, but it would not let me save, right off the bat.  Machine had been on for a while.

I shut the machine down, restarted, first opened Rh5, opened small file, rendered 3 passes, tried to save, would not let me.  Here's what was in the command history.

"Loading Flamingo nXt Beta Version 3.1.2011.1213, Date Built 13-Dec-2011
Flamingo nXt Beta will expire on 20 Mar 2012
Command: _Open
Name of the file to open ( UpdatePromptUpdateBlocks=Yes  Browse ): "\\laptop\my documents\calvino studio\20000AdditionRenovations\20006-11Diana\20006-11-00.3dm"
Loading Rhino Render, version 1.50, Jan  3 2012, 21:48:38
File "\\laptop\my documents\calvino studio\20000AdditionRenovations\20006-11Diana\20006-11-00.3dm" successfully read
Creating meshes... Press Esc to cancel
Command: _Render
Unable to create save bitmap
Unable to create save bitmap
Command: _CommandHistory"




If you create a completely new model on the Optiplex, 3 boxes.  Render it with default settings.  Does it save?

I setup a very similar box with Rhino 5.  It worked for me.  But, there could be something else going on.  WE still need to determine if it is Flamingo or the model.  The render test of a new model will show us.

Hi Scott,

I just opened Rh5 on the Optiplex, the machine was just booted and I had not run any other programs yet, I created 3 boxes of similar but slightly different sizes, as you described, then just clicked render (Flamingo nXt>Render)  I stopped it at 3 passes & tried to save.  Same message.  "Unable to create save bitmap"  F2 shows nothing further.

Hi Mike, are you using the 3gb switch in windows XP?

http://trebleclick.blogspot.com/2009/05/4gb-ram-xp.html

This makes the system unestable.

I am only using the 3gb switch on the laptop - that's the one that the save works sometimes on - I've been using the 3gb switch for like 3 yrs on it - no problems. 

On the Optiplex I don't have the 3gb switch running & it will not save at all, not even when first booted up.  The laptop at least will save an image when Rh5 is run first time after booting.  & actually I was able to save off about 5 images this afternoon.  Can not figure out what was different, but it let me save a few different renders from the same model right in a row.  But then on like the 5th or 6th try, it went back to the same error message.

I don't think it's the 3gb switch.

Thanks for the input though.

Mike -

I just released a new build 36.  Can you run this on your machines?  We hoep that you will see more information on the commandline to help us understand better what is happening.

To get the build, go to the Download Page....

I'll give it a try tonight or maybe tomorrow, thanks Scott.

I downloaded & installed, but it would not load when I started Rh5.  I got this error message (attached).  I'll try re-downloading & re-installing.

Attachments:

RSS

Members

© 2014   Created by Scott Davidson.

Badges  |  Report an Issue  |  Terms of Service