Flamingo nXt

easy rendering for Rhino in Windows

I am trying to render a model using the Flamingo nXt beta module build 26-Mar-2012 with Rhino 5 (build 31-May-2012).

It appears that when I use a material, it renders normally. However, if I make any change whatsoever to that material, the model reverts to the default of no material at all!

I am ready to upgrade from the beta of nXt to the production version but if I have the same issue with either version I am reluctant to drop the cash until it is fixed.

Any suggestions ?

Views: 1271

Reply to This

Replies to This Discussion

  1. Are you using Flamingo materials in the Flamingo Material editor?
  2. Does the material go black in the Flamingo Render or in the Rhino viewport?

Can you attach the model here? 

I am using Flamingo materials - solid colors.

I've done a little more testing. It appears to render fine ONLY with exterior lighting - any other mode & the model uses no materials.

The model is too big to attach (42,899kb). However here are 2 renders:

Model is painted using Flamingo solid matt black

Test1.jpg is using default studio lighting
Test2.jpg is using default exterior lighting

Notice in the exterior, I can get it to render correctly. However, any other lighting method results in the default coloring.

Attachments:

Is there reflectivity in your material?

For the exterior lighting, if you push up the brightness in the adjsut image after rendering, so you get to the correct material color?  It seems that a flat grey out in the sky could go quite dark if there is nothing else in the scene.

I am using Flamingo materials - solid colors.

I've done a little more testing. It appears to render fine ONLY with exterior lighting - any other mode & the model uses no materials.

The model is too big to attach (42,899kb). However here are 2 renders:

Model is painted using Flamingo solid matt black

Test1.jpg is using default studio lighting Test2.jpg is using default exterior lighting

Notice in the exterior, I can get it to render correctly. However, any other lighting method results in the default coloring.

In the post effects, I can lighten/darken. However it takes -300 on the brightness to get it down to where is starts to look like the exterior render.

I have a attached a rhino render using logrithmic.

Attachments:

Here is a sample model we can pass back and forth.  Does this file have a similar issue?

how dark do you want this paint?

Attachments:

Looks like we might be getting close to the problem. When I open your model, it opens fine. However, when try to look @ materials, lighting, or envorinment, I get the following:

"The Material Editor is not supported by the current render plug-in"

I do have Flamingo enabled as the current renderer.

Rhino 5 and Flamingo NXT? Are you accessing the material through the Flamingo Control panel?

Here is another run at this with a few material ideas.

using a light Rubble texture with a big scale.

This uses a dirt texture.

The materials are in the attached 3dm

Attachments:

Ok, I did the exact same thing with your model as with mine.

Same result.

So, this means *I* am doing something very wrong with the studio lighting functions. It is as if there is way too much lighting on the model perhaps ?

 

What you are seeing is the Tone operator messing with the image.  This is a black object by itself in the middle of nothing.  The Tone operator is trying to adjust the image to have both whites and blacks, a well balanced image.  Of course this is not what you want.  

So, it comes down to what you do want.  If this is the extent of the rendering, the sub by itself, then adjust the brightness until it looks right.  The settings could be very different from on lighting setup to another.

So, the question is how dark do you want it.

When I look at subs, they have a very interesting finish.  They have a little gloss to them, also the skin of the subs seem to be less then perfect over time.  I have added some gloss and texture to the finish.

Unfortunately, I need a fairly dark sub (subs are generally painted matt black) on a white background.

If the tone operator is mucking the image, how do I get around this ?

Use the Tone operator to your advantage.  Here is a selection.

Brightness 0 Burn 0

Brightness 0.46 burn 0

Brightness -0.55 Burn 0.33

Adding a little gloss to the material will help bring out some features.

RSS

Members

© 2018   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service