Flamingo nXt

easy rendering for Rhino in Windows


I've been using nXt with no issues for a while. However, it's suddenly playing up a LOT since the latest download. My main issue is that when I add a new material to a model, it takes on the properties of whatever material I previously used, and even though it displays as the new material, the software appears to treat it as the old one. I also can't use the dropdown material tree; the program just stops responding when I try to open it. 

For an example of the first issue. I just pulled "Oak- white- polished" into my material list. I then proceeded to pull smooth glass, anodised alum, stainless screen, ceramic tiling and roofing slate into the list as well. I just tried double-clicking on the smooth glass, though, and the modification window that opened was for "Oak-white-polished". 

This is a real nuisance, as I'm now limited to whatever material I add to the model first. Is there something wrong with my setup or is it a problem with the software?

I have attached a screenshot. As you can see, stainless screen is highlighted because that's what I clicked on, but the open window is for oak. 



Views: 1351


Reply to This

Replies to This Discussion

Hey Jack

I have the same problem. For now, as a workaround, I find that if I save my work, close Rhino, re-open it, load the model, then go straight to the materials control panel, I'm able to add materials without a problem. If I work in the model for a bit, and try and add a material or assign a new material to something I get the behaviour you describe.


Good to know I'm not the only one! Thanks for the tip, I'll do that for now, but hopefully there'll be a fix in the works with the next build... 


I was having the same problem, what version are you using?

Version 40 came out a few days after you posted this. I just downloaded this versions, and i've had no problems so far.

You're right, I'm on an earlier version. I'll change that right away!

Sorry took me a few days to get back to this. I'm using the latest version and still having a problem where after working for a while, if I add a new material to "Materials in Model" and then apply it to a layer, some other seemingly random material gets applied. Also not sure this is consistent behaviour, but when I save and close, then reopen rhino, that recently created material has vanished. I then have to remake and apply right away before doing anything else.

Hi Ryan.

Could you post the model?

Could you post a step by step description so we can reproduce it here.

Thank you.

I can't post the model (It's 300 mb and top secret!) but I took some screenshots.

1 - Materials window. Click new solid material.

2- Set up mateiral.

3- Material appears in window. All OK so far.


4- Click material button in layer list.

5- Choose the new material.

6- And the wrong material appears.


I've just had the same problem again, and I'm on the latest install (March 7 I believe). 

I pulled a bunch of materials into the palette in one go. They're all fine. Then the next day, I pulled in one more, and it took on the characteristics of the very last material I'd added the previous day. It lists as Aluminium (satin) and renders as transparent plastic (see screenshot). 


I'm sorry, i cant reproduce it here. I'va also tried with materials with a dash name on them, but couldnt reproduce it.

Rhino 4 or 5.

Windows XP, vista, 7?

Windows 7, Rhino 4. I think it might be particularly if you drag a material straight from the folders to the model, instead of first to the palette and then to the model.

Hi, Same problem here. Materials switch properties in an unpredictable way. This has been going on for some time on and off. But it happened immediately after latest download today.

I am having other odd material problems too. A solid behind a glass material turns transparent? Model attached for review.




© 2020   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service